20 lines
450 B
Text
20 lines
450 B
Text
#!/sbin/openrc-run
|
|
|
|
name=$RC_SVCNAME
|
|
description="Pterodactyl Panel Containerized"
|
|
supervisor="supervise-daemon"
|
|
|
|
command="/usr/share/pterodactyl-panel/pterodactyl-panel.sh"
|
|
command_args="start $(ip a | grep "state UP" -A2 | grep inet | awk '{$1=$1};1 {split($2,a,"/"); print a[1]}')"
|
|
|
|
depend() {
|
|
need net
|
|
after docker
|
|
need docker
|
|
}
|
|
|
|
stop() {
|
|
ebegin "Stopping $RC_SVCNAME"
|
|
/usr/share/pterodactyl-panel/pterodactyl-panel.sh stop
|
|
eend $?
|
|
}
|